УДК 316.023.4

АЛГОРИТМ ОБРАБОТКИ ДАННЫХ СОЦИОМЕТРИЧЕСКОГО ОПРОСА ИНСТРУМЕНТАМИ MICROSOFT EXCEL

Чуднова Ольга Владимировна
Сахалинский государственный университет
кандидат социологических наук, доцент кафедры социологии

Аннотация
В данной статье анализируются возможности обработки первичных данных социометрического опроса в среде Microsoft Excel, приводится подробный, пошаговый алгоритм работы с указанной программой.

Ключевые слова: групповая динамика, обработка социологических данных, первичные группы, рефренометрия, социометрия


THE ALGORITHM OF DATA PROCESSING SOCIOMETRIC SURVEY INSTRUMENTS MICROSOFT EXCEL

Chudnova Olga Vladimirovna
Sakhalin State University
candidate of sociological Sciences, associate professor of sociology

Abstract
This article examines the possibility of processing of initial data the sociometric survey in Microsoft Excel, provides a detailed, step-by-step algorithm with the specified program.

Рубрика: Социология

Библиографическая ссылка на статью:
Чуднова О.В. Алгоритм обработки данных социометрического опроса инструментами Microsoft Excel // Психология, социология и педагогика. 2016. № 11 [Электронный ресурс]. URL: http://psychology.snauka.ru/2016/11/7375 (дата обращения: 27.05.2017).

Социометрическая методика, разработанная социальным психологом Якобом Леви Морено, применяется для первичной диагностики и дальнейшей коррекции уровня развития взаимоотношений внутри членов малого контактного коллектива, период взаимодействия, между участниками которого составляет не менее полугода. Предложенная методика позволяет выявить формальную и неформальную структуру группы, степень взаимного притяжения и отталкивания членов коллектива и как следствие степень их социально-психологической совместимости, внутригрупповое положение (статус) каждого человека в группе, оценить социально-психологический климат внутри любого малого коллектива.
При проведении социометрического опроса отношения, имеющие место в коллективе находят конкретное выражение в таблицах и индексах, подсчет которых является трудоемкой процедурой. Упростить выполнение обработки итогов диагностических процедур призваны несколько программных комплексов, разработанных российскими и украинскими специалистами (Sociometry Pro, Соцiометрiя и т.п.), однако их использование может быть затруднено высокой стоимостью программ. В таком случае помочь исследователю может установленная на большинстве современных компьютерах офисная программа Microsoft Excel.
На первом этапе подготавливается социоматрица выборов, где отражается позитивное (1), или негативное (-1) отношение участников группы друг к другу. Ячейки, запрещающие самовыбор закрашиваются нажатием на них левой копкой мыши, далее выбор «Формат ячеек» – вкладка «Заливка», далее необходимо выбрать любой цвет и нажать «Ok» (см. рис 1.)

рис. 1. Первый шаг обработки социометрических данных

Ниже под фамилиями подсчитываем число полученных положительных голосов, формула будет иметь вид:

=СЧЕТЕСЛИ(C2:C7;1)

где C2:C7 диапазон ячеек, значения в которых необходимо вычислить, 1 – показатель положительного отношения одного человека к другому в нашем исследовании.
Для того чтобы не дублировать формулу под каждым участником, ее можно «растянуть», выделив ячейку содержащую формулу, а появившейся черный маркер заполнения потянуть вправо. (см. рис. 2)

рис. 2 Маркер автозаполнения ячеек

Далее подсчитывают количество полученных негативных голосов. При этом формула будет иметь вид:

=СЧЕТЕСЛИ(C2:C7;-1)

где C2:C7 диапазон ячеек, значения в которых необходимо вычислить, -1 – показатель отрицательного отношения одного человека к другому в нашем исследовании.
После этого мы можем узнать статус каждого человека, входящего в изучаемый коллектив. Формула подсчета будет иметь вид:

=СУММ(C2:C7)

где C2:C7 – диапазон ячеек, которые необходимо суммировать (см. рис. 3)

рис. 3. Второй шаг обработки социометрических данных

Для дальнейшей работы с индексами, характеризующими уровни группового развития, может понадобиться показатель количества положительных и отрицательных выборов, сделанных участниками опроса. Для этого справа от социоматрицы, аналогично предыдущим вычислениям, подсчитываем число отданных положительных и отрицательных голосов, используя формулу вида:

=СЧЕТЕСЛИ(C2:H2;1)  и   =СЧЕТЕСЛИ(C2:H2;-1)

где C2:H2 – диапазон ячеек, сумму в которых необходимо сосчитать, а 1 или -1 – условия отрицательного или положительного выбора. (см. рис. 4)

рис. 4. Третий шаг обработки социометрических данных

Общая сумма выборов (как положительных, так и отрицательных) вычисляется с помощью суммирования количества заполненных ячеек с помощью формулы вида:

=СЧЁТЗ(C2:H7)

где C2:H7 – диапазон ячеек, в которых необходимо произвести расчет.
Аналогичным образом подсчитываем количество возможных не сделанных (проигнорированных) выборов, т.е. пустых ячеек. Формула приобретет следующий вид:

=СЧИТАТЬПУСТОТЫ(C2:H7)-6

где C2:H7 – диапазон ячеек, в которых необходимо произвести расчет, 6- количество участников социометрического опроса (поскольку участник не может выбрать сам себя).
Сумма абсолютно всех выборов может быть посчитана по формуле:

=СУММ(C11:C12)

где C11:C12 ячейки с количеством сделанных и проигнорированных выборов (см. рис. 5).
рис. 5. Четвертый шаг обработки социометрических данных

Далее нам необходимо посчитать количество взаимных положительных и отрицательных выборов. Для этой цели необходимо транспонировать таблицу. Выделяем диапазон ячеек, характеризующий выборы участников социометрии и копируем их (см. рис. 6).

рис. 6. Первый шаг транспонирования таблицы.

Далее воспользуемся функцией «Специальная вставка». Щелкнув правой кнопкой мыши по той ячейке, в которую планируем скопировать таблицу (см. рис. 7).

рис. 7. Второй шаг транспонирования таблицы

В открывшемся окне ставим галочку «транспонировать» (см. рис. 8).

рис. 8. Третий шаг транспонирования таблицы.

Таблица в зеркальном отображении появится в указанном месте (рис 9.)

рис. 9. Вставка транспонированной таблицы.

Далее нам необходимо, вычислить, сколько взаимных выборов было сделано в группе. Для этого используем формулу вида:

=ЕСЛИ(C2=C16;(ЕСЛИ(C2=0;0;1));0)

где  С2 и С16 ячейки, которые необходимо сравнить между собой. Данные, полученные в ячейке «растягиваем» по количеству участников обследуемой группы. В получившейся таблице взаимные выборы отображаются цифрой 1 (см. рис 10).

рис. 10. Пятый шаг обработки социометрических данных

Теперь мы можем вычислить количество взаимных положительных и отрицательных выборов и перейти к расчету групповых и персональных индексов. Основными персональными индексами являются: индекс социометрического статуса (для выбираемого) и индекс эмоциональной экспансивности.
Индекс социометрического статуса – это показатель позиции члена группы, в котором отражается степень влияния человека на других людей, потенциальная способность к лидерству. Данный показатель может быть положительным и отрицательным и вычисляется по формулам:

где B+ – количество полученных индивидом положительных выборов, B- – количество полученных им отрицательных выборов, N – число членов группы.
Соответственно в нашем примере формула подсчета положительного и отрицательного индексов для первого участника будет иметь вид:

 =C8/(6-1)   и   = C9/(6-1)

С помощью маркера заполнения произведится подсчет индексов и для других испытуемых (см. рис 11).

рис. 11. Шестой шаг обработки социометрических данных

Эмоциональная экспансивность – показатель желания индивида определять отношения симпатии и антипатии к другим членам группы. Это важнейшая характеристика степени общительности человека. Индекс общей экспансивности рассчитывается по формуле:

где V+ - количество сделанных респондентом положительных выборов, V- - количество сделанных им отрицательных выборов, N – число членов группы.
В нашем примере эмоциональная экспансивность будет иметь вид:

=(I2+J2)/(6-1)

Основными групповыми индексами являются индексы экспансивности группы и взаимности выборов (сплоченности группы).
Индекс групповой экспансивности  подсчитывается по формуле:
где V+N – сумма всех положительных выборов в группе, V-N – сумма всех отрицательных выборов, N – численность группы.
Для нашего исследования подсчет будет иметь вид:

=СУММ(I2:J7)/6

где I2:J7 – диапазон ячеек, в которых отражены выборы участников группы
Индекс психологической взаимности выборов характеризует степень групповой сплоченности. Он выражает «удельный вес» положительной взаимности отношений в коллективе по отношению к идеальной возможной взаимности (в %). Определяется по формуле:

где X+ - число положительных взаимных связей в группе.
В нашем случае формула подсчета будет иметь вид:

= (100*C14)/(0,5*6*(6-1))

В целом вычисления по итогам социометрического опроса могут выглядеть следующим образом (см. рис. 12)

Рис. 12. Представление итогов социометрического исследования.

Таким образом, путем использования несложных стандартных формул офисный пакет Microsoft Excel в сжатые сроки позволяет качественно и быстро обработать большой массив социометрических данных и значительно упростить задачу психолога или социолога по работе с первичными данными, полученными в ходе исследования.


Библиографический список
  1. Морено, Якоб Леви Социометрия: Экспериментальный метод и наука об обществе. – М.: Академ. Проект, 2004. – 315 с.
  2. Карпова, Г. А. Педагогическая социометрия ученического коллектива. – Екатеринбург, 1997. – 29 с.


Все статьи автора «Чуднова Ольга Владимировна»


© Если вы обнаружили нарушение авторских или смежных прав, пожалуйста, незамедлительно сообщите нам об этом по электронной почте или через форму обратной связи.

Связь с автором (комментарии/рецензии к статье)

Оставить комментарий

Вы должны авторизоваться, чтобы оставить комментарий.

Если Вы еще не зарегистрированы на сайте, то Вам необходимо зарегистрироваться: